Moodle Association of Japan Discussion Forum

Grade book problems

Grade book problems

by David CAMPBELL -
Number of replies: 2

I have posted this to the enrolment forum at Moodle.org, but I have gotten any responses. I hope there is someone here who may have an answer.

I have a course that has students enrolled using the meta course link enrolment method. It has worked fine (except for lack of groups), but now that I am getting ready to do grades for the course I have found that grades for some activities for some students in the main course and the meta linked course aren't showing in the grade book. I can see the activities have been graded when I go to the activity, but there is just a hyphen - in the grade box in the grade book.

I solved the problem in the main course by unenrolling the student and then enrolling them again. That didn't solve the problem in the meta course and you can't go in and individually unenroll a student in a meta linked course. 

My question is:

Can I delete the meta course link enrolment method and then create the link again to have the students enrolled again in the meta course (I will have to create the groups again.) in hopes that grade book will be populated with the correct grades? Will I lose all of their grades for the meta course?

I am using Moodle 2.2.2 (Build:20120312)

As my grades are due soon, this is kind of urgent.

In reply to David CAMPBELL

Re: Grade book problems

by Kenlay FRIESEN -

Hello David,

I've had a similar problem. I've no idea why it happened, but grades entered were not appearing in the gradebook, just a dash, as you said. I was not using a meta-course so I didn't have that problem.

I tried a variety of things, and found that if I re-entered the grades in the activity (not in the gradebook directly), and then saved them of course, the grades appeared. In one activity I printed the results so I had a record, then deleted the entire activity, made a new activity, and reentered the grades. They appeared fine after that.

A work-around solution is to go into the Gradebook, turn editing on, and manually enter the grades. This 'override' function replaces whatever they received in the activity. Once you've done this, you can reverse it by clicking the 'edit grade' icon next to the grade in the Gradebook, and then un-check 'overridden'. The grade then reverts to the grade from the activity. You might want to try this (enter a phony grade through the override function, save it, then cancel the override) and see if the original activity grade pops up. I have a feeling this will work. Of course, this is all time consuming, but if it is only a few grades, it would work.

This happened to me with only one course (2.4 version) but it happened with a number of activities in that course. No idea why.

If these ideas don't work, let me know, and I'll play around a bit with it later today.

 

In reply to Kenlay FRIESEN

Re: Grade book problems

by David CAMPBELL -

Kenlay,

Thanks for the information. I had thought about the manual override idea, but there are quite a few students in the Meta course that are having this problem, so it will be time consuming to do so. I am thinking of making a backup of the meta course grades and activities and then try deleting the meta course enrolment method and installing it again to see if the grades will appear. It makes me nervous because if it doesn't work and then the backup doesn't reinstall correctly I am in trouble. I will probably go through and get all the grades and then try it just to see if it is possible for future reference.